Help > Older Browser Support

Older Browser Support

Effective December 22, 2015, we have upgraded the security settings on our website server. As part of this upgrade - which was required to remain PCI COMPLIANT with our credit card processor, Wells Fargo - we discontinued support for some legacy security protocols: SSLv3.0 and TLSv1.0.

SSLv3.0 and TLSv1.0 are considered "legacy" HTTPS security standards found in older browsers - such an EXPLORER 8 (shipped with WindowsXP).  Disabling these two security protocols will disallow about 1.5% of our customers from viewing secure pages, and will show errors on their screen when attempting to start a "checkout process".

Most modern browsers for all operating systems released within the last 5 years use the NEW version of TLS (v1.1 and v1.2) and are fully supported.  Click HERE to view browsers that now support TLSv1.1.

Below is a list of the most popular desktop browsers that are currently supported

CHROME: v22 or higher (version 48 is the most current)
ANDROID: v5.0 or higher (version 6.0.1 is the most current)
FIREFOX: v27 or higher (version 44 is the most current)
EXPLORER: v8 (ONLY when used with Windows 7 or higher). IE 8 used with Windows XP NOT supported
EXPLORER: v11 (only available with Windows 7 or higher)
OPERA: v17 (v35 is the most current)
SAFARI: v7 (v9 is the most current)

We HIGHLY recommend that you upgrade your browser to one of the browsers in the above list.  Older operating systems (such as Windows XP) unfortunately can not use IE8.  However, you CAN install CHROME or FIREFOX which will include the updated security protocols that will allow you to successfully shop at our on-line store.